Technology – Denodo ODBC And JDBC Driver Virtual DataPort (VDP) Engine Compatibility?

Technology - Denodo ODBC And JDBC Driver Virtual DataPort (VDP) Engine Compatibility?

Recently, while patching a Denodo environment, the question arose as to whether an older ODBC or JDBC driver can be used against a newer patched environment. It is described in the first paragraph of the denodo documentation, the directionality of the compatibility can be overlooked easily.

Can An Older ODBC Or JDBC Driver Be Used Against A Newer Past Environment?

The short answer is yes.  Denodo permits backward compatibility of older drivers with newer versions. Even across major versions for denodo version 7 and 8.

ODBC and JDBC driver Compatibility

The older ODBC and JDBC drivers can be of an update that is an older version (patch or major version) than the update installed on the server.

However, as is clearly stated in the documentation, you cannot use a newer driver against an older version of Denodo. This goes for denodo patch versions as well as denodo major versions. Connecting a Virtual DataPort server using an updated newer ODBC or JDBC on the Virtual DataPort (VDP) Engine server. This will not be supported, and it may lead to unexpected errors.

Related Denodo References

For more information about ODBC and JDBC drivers compatibility, please see these links to denodo

Documentation.

Denodo > Drivers > JDBC

Denodo > Drivers > ODBC

Backward Compatibility Between the Virtual DataPort Server and Its Clients

Leave a Reply